Belajar MikroTik di VMware Workstation – Konfigurasi OSPF

Setelah sebelumnya kita udah melakukan konfigurasi dasar MikroTik pada WS 10, sekarang waktunya melakukan konfigurasi yang agak advance, yaitu routing OSPF. Buat yang baru belajar mengenai konsep routing sebaiknya baca-baca dulu di sini. Sedangkan untuk studi kasus OSPF mengunakan MikroTik bisa mampir ke sini.

Lanjut ke praktek.

Kali ini kita punya topologi seperti gambar di bawah. Konfigurasi OSPF yang akan kita lakukan masih menggunakan single area, yaitu area backbone.

config ospf 1

Seperti biasa petunjuk awal yang harus dilakukan adalah pengaturan VMnet terhadap masing-masing interface MikroTik. Jangan sampai tertukar atau bahkan tidak di-assign. Salah sedikit fatal akibatnya sehingga berakibat interkoneksi antar MikroTik jadi kacau. Buat tabel bila perlu.

R1

Eth1: NAT

Eth2: VMnet2

Eth3: VMnet3

R2

Eth1: VMnet5

Eth2: VMnet2

R3

Eth1: VMnet3

Eth2: VMnet4

R4

Eth1: VMnet4

Eth2: VMnet5

Eth3: VMnet6

Apabila semua sudah sesuai maka sekarang waktunya memberikan IP Address pada setiap interface. Lihat topologi di atas apabila masih bingung.

R1

/ip address
add address=192.168.2.1/24 disabled=no interface=ether2 network=192.168.2.0
add address=192.168.3.1/24 disabled=no interface=ether3 network=192.168.3.0

R1 melakukan NAT

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

Aktifkan DNS

/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
max-udp-packet-size=4096 query-server-timeout=2s query-total-timeout=10s \
servers=192.168.225.2

Note: IP DNS server adalah IP host dari VMnet8 (NAT)

R2

/ip address
add address=192.168.2.2/24 disabled=no interface=ether2 network=192.168.2.0
add address=192.168.5.2/24 disabled=no interface=ether1 network=192.168.5.0

R3

/ip address
add address=192.168.3.3/24 disabled=no interface=ether1 network=192.168.3.0
add address=192.168.4.3/24 disabled=no interface=ether2 network=192.168.4.0

R4

add address=192.168.4.4/24 disabled=no interface=ether1 network=192.168.4.0
add address=192.168.5.4/24 disabled=no interface=ether2 network=192.168.5.0
add address=192.168.6.1/24 disabled=no interface=ether3 network=192.168.6.0

Setelah selesai memasukkan IP Address, sekarang waktunya kita melakukan konfigurasi OSPF. Secara sederhana yang perlu kita lakukan hanya memasukkan subnet network yang ingin di-advertise ke neighbour (router tetangga).

Kita verifikasi routing table R1 terlebih dahulu:

[admin@R1] > ip ro pr
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf, m – mme,
B – blackhole, U – unreachable, P – prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 ADS  0.0.0.0/0                          192.168.225.2             0
1 ADC  192.168.2.0/24     192.168.2.1     ether2                    0
2 ADC  192.168.3.0/24     192.168.3.1     ether3                    0
3 ADC  192.168.225.0/24   192.168.225.143 ether1                    0

Seperti yang kita lihat bahwa belum ada routing OSPF yang ditandai dengan huruf ‘o’. Router R1 belum bisa reach ke R4 (network .4, .5) dan juga PC A (192.168.6.0).

Mari kita aktifkan routing OSPF pada R1 terlebih dahulu. Masukkan semua network yang directly connected (terhubung langsung) dengan interface R1.

/routing ospf network
add area=backbone network=192.168.2.0/24
add area=backbone network=192.168.3.0/24

Kemudian lakukan hal yang sama pada R2.

/routing ospf network
add area=backbone disabled=no network=192.168.2.0/24
add area=backbone disabled=no network=192.168.5.0/24

Sisanya, R3 & R4 juga lakukan hal yang sama pula.

Apabila benar seharusnya sekarang pada setiap router sudah terdapat routing OSPF dengan nilai administrative distance  110.

Contoh yang nampak pada R3.

[admin@R3] > ip ro pr
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf, m – mme,
B – blackhole, U – unreachable, P – prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 ADo  192.168.2.0/24                     192.168.3.1             110
1 ADC  192.168.3.0/24     192.168.3.3     ether1                    0
2 ADC  192.168.4.0/24     192.168.4.3     ether2                    0
3 ADo  192.168.5.0/24                     192.168.4.4             110
4 ADo  192.168.6.0/24                     192.168.4.4             110

Muncul simbol ‘o’ yang menandakan routing protocol OSPF sudah berjalan dengan baik.

Nah, kemudian masalah baru muncul. PC A yang terhubung dengan R4 tidak dapat melakukan koneksi ke internet. Mengapa hal itu bisa terjadi? Padahal semua router sudah bisa saling komunikasi dan konek ke internet. Apa iya? mari kita periksa lagi routing table di atas. Jika Anda teliti maka dapat ditemukan bahwa tidak ada default gateway dalam routing table R2, R3 & R4 sehingga apabila ada klien di belakang mereka yang ingin melakukan koneksi internet maka akan keluar error ‘no route to host’ karena router tidak tahu akan dikemanakan paket tersebut.

Lalu bagaimana solusinya? Mudah saja, kita hanya perlu mengaktifkan fitur redistribute default pada R1 supaya default  gateway bisa di-advertise ke R2, R3 & R4.

/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=always-as-type-1 \

Mari kita lihat sekarang routing table pada R3.

[admin@R3] > ip ro pr
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf, m – mme,
B – blackhole, U – unreachable, P – prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 ADo  0.0.0.0/0                          192.168.3.1             110
1 ADo  192.168.2.0/24                     192.168.3.1             110
2 ADC  192.168.3.0/24     192.168.3.3     ether1                    0
3 ADC  192.168.4.0/24     192.168.4.3     ether2                    0
4 ADo  192.168.5.0/24                     192.168.4.4             110
5 ADo  192.168.6.0/24                     192.168.4.4             110

Yup, sudah ada default gateway 0.0.0.0/0 via R1 melalui protokol OSPF. Waktunya kita coba konek internet dari PC A.

config ospf 2Hore.. sudah berhasil.

Kita akan lihat flow paket dari PC A menuju ke ISP. Apakah via R2 atau R3.

config ospf 4

Ternyata flow paketnya adalah via R3

config ospf 3Jadi seperti ini PC A -> R4 -> R3 -> R1 -> Internet

Apakah selalu seperti itu flow paketnya? tidak juga. Mari kita lihat routing table pada R4.

[admin@R4] > ip route pr
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf, m – mme,
B – blackhole, U – unreachable, P – prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 0.0.0.0/0 192.168.4.3 110
192.168.5.2
1 ADo 192.168.2.0/24 192.168.5.2 110
2 ADo 192.168.3.0/24 192.168.4.3 110
3 ADC 192.168.4.0/24 192.168.4.4 ether1 0
4 ADC 192.168.5.0/24 192.168.5.4 ether2 0
5 ADC 192.168.6.0/24 192.168.6.1 ether3 0

Lihat pada baris 1 yang berisi default gateway. Terlihat ada dua exit interface yang ditawarkan oleh protokol OSPF untuk menuju ke internet. Ini artinya protokol OSPF menawarkan fitur yang sangat penting, yaitu load balancing dan fail over. Beban keluar akan dibagi secara seimbang dan apabila ada link yang down makan link lainnya dapat menjadi link cadangan. Enak, tho?

Oke sekian dulu mater tentang MikroTik menggunakan OSPF. Artikel selanjutnya kita kan bahas mengenai VRRP sebagai solusi FHRP. Nah, makin bingung toh? Hehe

So, stay tuned ya guys 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *