Konfigurasi Dasar 3CX – Part 1: Split DNS & Port Forward

Setelah kita berhasil menginstal 3CX, diperlukan konfigurasi dasar supaya kita dapat melakukan panggilan antar ekstensi dan bahkan melakukan panggilan keluar. Oleh karena itu ada beberapa hal yang harus dipersiapkan.

Di antaranya sbb:

  1. DNS Server –> metode yang terbaik adalah menggunakan split-dns. Artinya jika klien ingin menghubungi server dapat menggunakan DNS record dimana DNS record ini sudah di daftarkan ke dalam DNS server internal (privat) dan eksternal (publik). Nah, nanti jika klien ke luar kantor dia akan menghubungi IP publik, sedangkan selama di kantor dia akan menggunakan IP privat.
  2. Port forward –> standar yang digunakan untuk komunikasi antar voip dan juga antar ekstensi sudah ditetapkan. Jadi yang perlu kita lakukan adalah melakukan port forward dari arah router menuju server 3CX. Selain itu pastikan port ini juga dibuka jika di kantor Anda membatasi koneksi antar segmen menggunakan Firewall. Berikut list port yang harus di-port forward: https://www.3cx.com/docs/ports/

Berikut adalah contoh topologi sederhana sistem IP PBX menggunakan 3CX.

Topologi Sederhana 3CX

Sebagai catatan di atas router digunakan juga sebagai internal DNS server.

Dalam contoh kali ini akan diinformasikan konfigurasi DNS server internal dan juga port forward menggunakan perangkat MikroTik.

/ip dns static
add address=192.168.32.3 name=smartnet.3cx.com.my

add action=dst-nat chain=dstnat comment=3cx dst-port=5001 in-interface=ether4 \
protocol=tcp to-addresses=192.168.32.3 to-ports=5001
add action=dst-nat chain=dstnat dst-port=443 in-interface=ether4 protocol=tcp \
to-addresses=192.168.32.3 to-ports=443
add action=dst-nat chain=dstnat dst-port=5090 in-interface=ether4 protocol=\
tcp to-addresses=192.168.32.3 to-ports=5090
add action=dst-nat chain=dstnat dst-port=48000-65535 in-interface=ether4 \
protocol=udp to-addresses=192.168.32.3 to-ports=48000-65535
add action=dst-nat chain=dstnat dst-port=9000-10999 in-interface=ether4 \
protocol=udp to-addresses=192.168.32.3 to-ports=9000-10999
add action=dst-nat chain=dstnat dst-port=5090 in-interface=ether4 protocol=\
udp to-addresses=192.168.32.3 to-ports=5090
add action=dst-nat chain=dstnat dst-port=5061 in-interface=ether4 protocol=\
tcp to-addresses=192.168.32.3 to-ports=5061
add action=dst-nat chain=dstnat dst-port=5060 in-interface=ether4 protocol=\
udp to-addresses=192.168.32.3 to-ports=5060
add action=dst-nat chain=dstnat dst-port=5060 in-interface=ether4 protocol=\
tcp to-addresses=192.168.32.3 to-ports=5060

Jika sudah, pastikan setiap port dapat diakses baik dari dalam maupun luar (internet). Untuk pengetesan dapat menggunakan telnet atau aplikasi port scanner. Sedangkan untuk pengetesan split domain bisa menggunakan nslookup atau ping.

Berikut contoh hasil split DNS:

Jika di-ping/nslookup dari dalam:

Jika nslookup dari luar:

Untuk pengetesan port juga dapat menggunakan fitur Firewall check yang terdapat di 3CX. Fitur ini sangat berguna untuk memverifikasi semua port yang diperlukan untuk komunikasi dengan 3CX. Apabila masih ada tanda seru(!) merah artinya masih ada yang harus dibuka.

Berikut referensi konfigurasi MikroTik untuk 3CX: https://www.3cx.com/docs/mikrotik-firewall-configuration/

Di beberapa kasus SIP ALG MikroTik perlu di-nonaktifkan karena service tersebut akan di-handle oleh 3CX.

Leave a Reply

Your email address will not be published. Required fields are marked *

Hi there, welcome to my personal blog. Hope you enjoy visiting here. If you’d like to get in touch with me for either commercial and training purpose, feel free to reach my contact page. Cheers!